Tag Archives: blocked

Malaysia News Personal

Certain website has been blocked

I got really shocked this morning as I cannot access two of my web application that I’ve been developed for sometimes from my warm and cozy home. As this thing happen from time to time so I did not panic at all.

At first, I’m checking out the web server. When I ping it, I’ll trying to do a remote desktop to the server and its fine. I’ll try to access site locally and its working perfectly. Then I test accessing a different web application that I have there from home… and its working fine too. So nothing wrong in the web server.

Second, I’m doing a remote desktop to another server in Malaysia and I’ll try to access the site from there and all work. Nothing wrong.

Third, I try using my own computer again and I still cannot access the site. Thinking that it may be Windows Live 2011 cause as I just installed them in my computer, I use another notebook to access the site… and I still cannot access them. But when I try to access using a proxy… I can accessed the site perfectly. So the problem lies in my ISP.

Fourth, I try to reset my computer and even my router but I still cannot accessed it. And now I’m officially blamed Maxis my ISP which I suspected blocked my site. How could Maxis blocked my site? No illegal activity in there and nothing political in there too. So I go to Maxis website and fill in their Online Enquire and Feedback. I even thinking on changing my ISP if the problem persist. But suddenly everything when normal again in about 1 hour ago. Fiuh…

News Personal

Maxis Broadband blocked SMTP port 25

I just realized it last night when I’m trying to send email using my office SMTP Server and it fails. Thinking that my server down, I checked the web site and its working fine. I’ll try sending the email again and it fails again. Suspected that the SMTP services may be down, I do a remote desktop to the server just to find out that the services is working fine. I even try to send a test email using the local computer and it working perfectly. So its my be on my end and not on the server end. Checkout my firewall and everything and its fine. And my suspicious goes to my internet provider which is Maxis Broadband who may be blocked port 25. To prove it, I do a telnet to my server and found out that it cannot be connected. Finally, I checked with Maxis web site and found out that they DID actually blocked port 25 since March 2010.

So now I need to change our office SMTP port to 587 as this port was slated for SMTP submission while port 25 was used for SMTP relay. And the easy way to do this are by using port forwarding in our router to do this as I don’t want to change to many things in my office intranet.